Failed to start Raise network interfaces

En una instalación limpia de Debian 9 me salía este error:

# cat /var/log/syslog | grep Failed
Jul 2 09:30:02 debi systemd[1]: Failed to start Raise network interfaces.
Jul 2 09:30:02 debi systemd[1]: networking.service: Failed with result ‘exit-code’.

Y además, al lanzar:

$ ip a

Mostraba como nombre de red enp3s0 y no el clásico eth0:

# dmesg | grep eth0
[ 2.584092] r8168 0000:03:00.0 enp3s0: renamed from eth0

Si bien ni una cosa ni la otra eran graves ya que no evitaban poder navegar normalmente, si eran molestas para mi pobre sensibilidad.

A la espera de resolverlo más adelante, en un primer momento y para continuar teniendo la ip fija, he modificado el interfaces con los datos de la nueva red:

# nano /etc/network/interfaces

# The primary network interface
#allow-hotplug enp3s0
#iface enp3s0 inet dhcp

auto enp3s0
iface enp3s0 inet static
address 192.168.1.15
gateway 192.168.1.1
netmask 255.255.255.0
broadcast 192.168.1.255

Luego en linuxquestions indican que esto se resuelve modificando udev creando un archivo 10-network.rules:

# cat /etc/udev/rules.d/10-network.rules

Y añadir las lineas:

SUBSYSTEM==”net”, ACTION==”add”, ATTR{address}==”54:04:a6:a6:16:b3″, NAME=”eth0″
SUBSYSTEM==”net”, ACTION==”add”, ATTR{address}==”f8:d1:11:01:0d:88″, NAME=”eth1″

Con la ATTR{address} que muestra el propio comando ip a para cada tarjeta de red.

Al reiniciar la red, volvía a ser eth0 pero me salian dos ip, una con el número 15 y otra con el 33 en la misma máquina y una tarjeta de red:

$ ip a

eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether 54:04:a6:a6:16:b3 brd ff:ff:ff:ff:ff:ff
inet 192.168.1.33/24 brd 192.168.1.255 scope global eth0
valid_lft forever preferred_lft forever
inet 192.168.1.15/24 brd 192.168.1.255 scope global secondary eth0
valid_lft forever preferred_lft forever

Esto se resuelve editando el setup del interfaces.d:

# nano /etc/network/interfaces.d/setup

Y comentar las lineas correspondientes al dhcp:

auto lo
iface lo inet loopback

#auto eth0
#iface eth0 inet dhcp

Una vez reiniciada la máquina todo vuelve a ser normal.

 

Share

One comment

  1. Tomás Ystúriz dice:

    Resuelto el asunto con esta instrucción de comentar las líneas indicadas.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *